IE Compatability Issue: Solutions

If you are having trouble viewing news pages on any of our sites, the problem may be an old version of Internet Explorer, (older than IE 9). You should be able to check the version of IE you are using by selecting the “About Internet Explorer” item in the “Help” menu of Internet Explorer (instructions to check vary by the version).

Unfortunately there isn’t anything we can do for IE 8 and older. Essentially, IE 8 is tied with the Microsoft XP operating system, which is currently being phased out by Microsoft. Yale University is actively trying to upgrade any Windows XP systems before April 8th, when Microsoft support for XP will officially be dropped, which will also upgrade these systems to use IE 9 or a newer version. Any IE compatibility issues for news readers should be resolved by this upgrade.

  • In the meantime, any display issues can be addressed by upgrading your version of IE, the latest version is IE 11. You can download the latest version here: http://windows.microsoft.com/en-us/internet-explorer/download-ie-MCM
    • Then, go to Tools, select Compatibility View Settings. In the pop-up window that appears, you need to uncheck the “Display intranet sites in Compatibility View” box.
alt text
  • Alternatively, you can switch to Mozilla Firefox. If you’re unable to just install it (http://www.mozilla.org/en-US/firefox/new/) because you’re on a restricted managed workstation, I’d suggest you get in touch with the ITS Helpdesk and request it right away. Virtually all your viewing issues will go away just by changing the browser you use.